HostName Change in Solaris 11.4
ISSUE : Change hostname of a Solaris 11.4 server without reboot the server
GOAL : Change hostname of a Solaris 11.4 server without reboot the server
SOLUTION : Hostname change is very simple in solaris 11.4, Hostname change can be easily done with the below commands without reboot.
Prerequisites : Complete DNS registration and obtain appropriate IP address from network team
1. View the system hostname or the system identity.
bash # svccfg -s system/identity:node listprop config
2. Change the server name to JUDI-DEV-10 with the following command.
bash # svccfg -s system/identity:node setprop config/nodename="JUDI-DEV-10"
bash # svccfg -s system/identity:node setprop config/loopback="JUDI-DEV-10"
3. Refresh the system identity service with the following command.
bash # svcadm refresh system/identity:node
4. Restart the system identity service with the following command.
bash # svcadm restart system/identity:node
5. To view the modified hostname with the following command.
bash # svccfg -s system/identity:node listprop config
6. Update the /etc/hosts with hostname and appropriate IP with the following command.
bash # vi /etc/hosts
#::1 JUDI-DEV-10 localhost
127.0.0.1 localhost
192.168.10.10 JUDI-DEV-10
7. Delete the existing IP address and interface
bash # ipadm delete-ip net0
8. Create or plumb new network interface
bash # ipadm create-ip net0
9. Configure IP address to the interface net0
bash # ipadm create-addr -T static -a 19.168.10.10/23 net0/v4
10. To view the configured IP address
bash # ipadm show-addr
ADDROBJ TYPE STATE ADDR
lo0/v4 static ok 127.0.0.1/8
net0/v4 static ok 192.168.10.10/23
bash #
~Judi~
No comments:
Post a Comment