Popular Posts

May 18, 2017

Oracle Database Installation - Solaris Operating System


Anonymous Port Ranges
#Rule A00402: anon port range OK? (tcp_smallest_anon_port, tcp_largest_anon_port, udp_smallest_anon_port, udp_largest_anon_port)
           ipadm set-prop -p smallest_anon_port=9000 tcp
           ipadm set-prop -p largest_anon_port=65500 tcp
           ipadm set-prop -p smallest_anon_port=9000 udp
           ipadm set-prop -p largest_anon_port=65500 udp

WARNING => UDP socket receive buffer size is not set to recommended value of 65536
WARNING => UDP socket send buffer size is not set to recommended value of 65536
DATA FROM JUDI-DEV-001 - UDP SOCKET RECEIVE BUFFER SIZE
DATA FROM JUDI-DEV-001 - UDP SOCKET SEND BUFFER SIZE
recv_buf = 57344
send_buf = 57344
send_buf and recv_buf==>65536
           ipadm set-prop -p send_buf=65536 udp
           ipadm set-prop -p recv_buf=65536 udp
           ipadm show-prop udp
           ipadm show-prop tcp

#Oracle DBA Installation in solaris 10
           /usr/sbin/ndd -set /dev/tcp tcp_smallest_anon_port 9000
           /usr/sbin/ndd -set /dev/tcp tcp_largest_anon_port 65500
           /usr/sbin/ndd -set /dev/udp udp_smallest_anon_port 9000
           /usr/sbin/ndd -set /dev/udp udp_largest_anon_port 65500

#A02210 Kernel Parameters OK FAILED  SHMMAXTooSmall
           projmod -s -K "project.max-shm-memory=(priv,19327352832,deny)" user.oracle    (18GB - set as pet DBA request)
           prctl -n project.max-shm-memory -t privileged  $$

#A02020 ulimits OK?          FAILED  NoFilesSoftTooSmall
WARNING => Oracle database software owner soft nofile shell limits is not configured according to recommendation
DATA FROM JUDI-DEV-001 - ORACLE DATABASE SOFTWARE OWNER SOFT NOFILE SHELL LIMITS
oracle user'ssoft nofile shell limit = 256
The soft nofile shell limit for the Oracle DB software install owner should be >= 1024
           projmod -s -K "process.max-file-descriptor=(basic,1024,deny)" user.oracle
           ulimit -sa (Check the below value - should be 1024 from 256)
           nofile                         (-n)  1024

#A00110 ulimits OK?          FAILED  StackHardUnlimited (ulimit -Sa - check stack value)
#A02020 ulimits OK? FAILED StackHardUnlimited (ulimit -Ha - check stack value)
WARNING => Oracle database software owner soft stack shell limit is configured according to recommendation
DATA FROM JUDI-DEV-001 - ORACLE DATABASE SOFTWARE OWNER SOFT STACK SHELL LIMITS
oracle user's soft stack shell limit = 8192
The soft stack shell limit for the Oracle DB software should be >= 10240.If the soft stack limit is 10240 or above then the configuration should be OK.
oracle user's soft stack shell limit = unlimited
The Hard stack shell limit for the Oracle DB software should be = 32768.The default soft stack limit is "unlimited" Should change to  OK.
           projmod -s -K 'process.max-stack-size=(basic,10MB,deny),(privileged,32MB,deny)' user.oracle
           su - oracle -c "ulimit -Hs ; ulimit -Ss"(su to oracle and Check the below value - Should be 10240) OR
           ulimit -Ss and ulimit -Hs
           stack size (Kibytes)           (-s)  10240

#A00320 /etc/hosts Format    FAILED  No entry found
#host file entry should be in the below format
           192.168.1.20   judi-dev-01.corporate.com   judi-dev-01  loghost

#A00330 Kernel Parameters OK FAILED  NOEXEC_USER_STACKUndef
Update the below values in /etc/system and reboot the server
           set noexec_user_stack = 1
           set noexec_user_stack_log = 1
           forceload: sys/shmsys
           forceload: sys/semsys
           chmod 644 /etc/system

# oracheck for oracle installation
           cd /opt/oracle//work/RDA/rda/
           sh -x ./rda.sh -T hcve 
           Select the required Oracle database version option to do the pre-check

Find Oracle RAC cluster service is running or not
           ps -ef | grep crsd.bin | grep -v grep
           /opt/oracle/12.1.0.2/grid/bin/crsd.bin reboot    (This Process will run in RAC Cluster Nodes)

Find Oracle RAC Partner Nodes
           . oraenv
           +ASM1    (should be ASM2 if we execute in other node {ps -ef | grep asm})

           olsnodes
           
Unix command to find Oracle version number
           cat /var/opt/oracle/oratab | grep prod





~
soft limit maximum stack size solaris 11
~

No comments:

Post a Comment

Popular Posts