Popular Posts

Nov 23, 2017

Solaris 10 x86 SVM Patching

Solaris 10 x86 SVM Patching
Solaris 10 SVM Patching (x86)

Step 1:     Backup the necessary configuration file and save it
                          df -h
                          metastat -p
                          metadb
                          echo | format
                          prtconf -v | sed -n '/bootpath/{;p;n;p;}'
                  Root Disk - c0t0d0
                  Root Mirror Disk - c0t1d0
                  6 copies of metadb replicas - c0t0d0s7 and c0t1d0s7
                  Current Kernel - 147441-01

Step 2:      Detatch the submirrors and clear them
                  /dev/md/dsk/d0 /
                  /dev/md/dsk/d1 swap
                  /dev/md/dsk/d3 /var
                  /dev/md/dsk/d4 /opt/BMC

                   JUDI-DEV-TEST01# metastat -p
                   d4 -m d14 d24 1
                   d14 1 1 c0t0d0s4
                   d24 1 1 c0t1d0s4
                   d3 -m d13 d23 1
                   d13 1 1 c0t0d0s3
                   d23 1 1 c0t1d0s3
                   d1 -m d11 d21 1
                   d11 1 1 c0t0d0s1
                   d21 1 1 c0t1d0s1
                   d0 -m d10 d20 1
                   d10 1 1 c0t0d0s0
                   d20 1 1 c0t1d0s0
                   JUDI-DEV-TEST01#
                          metastat -p
                          metadetach d0 d20
                          metadetach d1 d21
                          metadetach d3 d23
                          metadetach d4 d24

                          metastat -p

                          metaclear d20
                          metaclear d21
                          metaclear d23
                          metaclear d24

                          metastat -p

Step 3:      Remove replicas added on root mirror disk
                          metadb
                          metadb -d c0t1d0s7
                          metadb

Step 4:      Install grub on root mirror disk to make sure the disk is bootable incase we want to back-out the patching
                          installgrub -m /boot/grub/stage1 /boot/grub/stage2 /dev/rdsk/c0t1d0s0

Step 5:      Mount root Mirror disk c0t1d0s0 on mnt
                          mount /dev/dsk/c0t1d0s0 /mnt
                          df -h /mnt

Step 6:      Modify /mnt/etc/vfstab & /mnt/etc/system files
                          cat /mnt/etc/vfstab
                          vi /mnt/etc/vfstab
                          /dev/dsk/c0t1d0s1  -       -       swap    -       no      -
                          /dev/dsk/c0t1d0s0  /dev/rdsk/c0t1d0s0 /       ufs     1       no      -
                          /dev/dsk/c0t1d0s3  /dev/rdsk/c0t1d0s3 /var    ufs     1       no      -
                          /dev/dsk/c0t1d0s4  /dev/rdsk/c0t1d0s4 /opt/BMC        ufs     2       yes     -

                          tail /mnt/etc/system
                          vi /mnt/etc/vfstab (Comment the mirror related information)
                          * Begin MDD root info (do not edit)
                          * rootdev:/pseudo/md@0:0,0,blk
                          * End MDD root info (do not edit)
                          * set md:mirrored_root_flag=1

Step 7:      Delete existing boot sign on root mirror disk and create unique one
                          ls -l /mnt/boot/grub/bootsign/
                          -r--r--r--   1 root     root           0 Oct 17  2013 rootfs0

                          rm /mnt/boot/grub/bootsign/rootfs0
                          touch /mnt/boot/grub/bootsign/rootfs1
                          ls -l /mnt/boot/grub/bootsign/

Step 8:      Update root mirror disk menu.lst file
                          ls -lrt /mnt/boot/grub/menu.lst
                          cat /mnt/boot/grub/menu.lst

                  Edit the file and change the rootfs0 to rootfs1 in both lines and change the title as Root Mirror Disk
                          vi /mnt/boot/grub/menu.lst
                          #---------- ADDED BY BOOTADM - DO NOT EDIT ----------
                          title Root Mirror Disk Oracle Solaris 10 8/11 s10x_u10wos_17b X86
                          findroot (rootfs1,0,a)
                          kernel /platform/i86pc/multiboot
                          module /platform/i86pc/boot_archive
                          #---------------------END BOOTADM--------------------
                          #---------- ADDED BY BOOTADM - DO NOT EDIT ----------
                          title Solaris failsafe
                          findroot (rootfs1,0,a)
                          kernel /boot/multiboot -s
                          module /boot/amd64/x86.miniroot-safe
                          #---------------------END BOOTADM--------------------

                          cat /mnt/boot/grub/menu.lst

Step 9:      Update boot environment variable on root mirror disk
                          echo | format
                          cat /mnt/boot/solaris/bootenv.rc
                          ls -ld /dev/dsk/c0t1d0s0
                          lrwxrwxrwx   1 root     root          62 Oct 17  2013 /dev/dsk/c0t1d0s0 -> ../../devices/pci@0,0/pci8086,3c06@2,2/pci1028,1f38@0/sd@1,0:a
                          vi /mnt/boot/solaris/bootenv.rc
                          setprop bootpath '/pci@0,0/pci8086,3c06@2,2/pci1028,1f38@0/sd@0,0:a' ----> Remove this line
                          setprop bootpath '/pci@0,0/pci8086,3c06@2,2/pci1028,1f38@0/sd@1,0:a' ----> Add the secondary disks path here

Step 10:      Update boot disks menu.lst file,
                  This step will allow us to skip the step of configuring BIOS to boot from root mirror disk
                          cat /boot/grub/menu.lst
                  Edit the file and make entry to list out the secondary disk as separate boot disk while grub booting screen comes
Add the below entry to the bottom of the file - secondary disk - rootfs1
                          #---------- ADDED BY BOOTADM - DO NOT EDIT ----------
                          title Root Mirror Disk - Oracle Solaris 10 8/11 s10x_u10wos_17b X86
                          findroot (rootfs1,0,a)
                          kernel /platform/i86pc/multiboot
                          module /platform/i86pc/boot_archive
                          #---------------------END BOOTADM--------------------
                          #---------- ADDED BY BOOTADM - DO NOT EDIT ----------
                          title Solaris failsafe
                          findroot (rootfs1,0,a)
                          kernel /boot/multiboot -s
                          module /boot/amd64/x86.miniroot-safe
                          #---------------------END BOOTADM--------------------

Step 11:      Check the currently booted device
                          prtconf -v | sed -n '/bootpath/{;p;n;p;}'
                  Currently server booted from root disk, Now restart and boot from root mirror disk
                          init 6
                  Server will display as
                  creating boot_archivee for /mnt
                  updating /mnt/platform/i86pc/boot_archive

                  while rebooting slect the root mirror disk from grub menu - to check the root secodary disk is safe to boot.
                  Check from which disk the server is booted and make sure the disk booted from root mirror - now we are good to proceed patching
                          prtconf -v | sed -n '/bootpath/{;p;n;p;}'

Step 12:      Reboot the server to boot from boot disk see the root disk status
                          init 6
                  Check from which disk the server is booted and make sure the disk booted from boot disk - Primary disk
                          prtconf -v | sed -n '/bootpath/{;p;n;p;}'

Step 13:      Bring the server into single user mode and install the patches
                          who -r
                          init s

Step 14:      Start install the patches
                          ./installpatchset --s10patchset

Step 15:      Patch installation completed, Reboot the server
                          init 6
                  Verify the new patch version and smf status
                          uname -v
                          svcs -xv
                          df -h

Step 16:      Now create submirrors and replicas on root mirror disk
                          echo | format
                          metstat -p
                          metainit -f d0 1 1 c0t1d0s0
                          metainit -f 21 1 1 c0t1d0s1
                          metainit -f 23 1 1 c0t1d0s3
                          metainit -f 24 1 1 c0t1d0s4

Step 17:      Attach submirrors to the main mirror
                          metadb -afc3 c2t0d0s7
                          metadb
                          metstat -c

                          metattach d0 d0
                          metattach d1 d21
                          metattach d3 d23
                          metattach d4 d24

                          metastat -c
                  Wait until the resync completes

                          uname -X
                          metastat -c d0

                  Once the resync completed, Reboot the server
                          init 6



Solaris10
Solaris 10 x86 SVM Patching
Solaris 10 SVM Patching (x86);
how to patch solaris 10 x86 server;
Update Solaris 10 kernel version;
Solaris 10 x86 Kernel patching;

~Judi~




No comments:

Post a Comment

Popular Posts